website statistics Release - Perfect World Private Server Installation Script | Page 2 | hrace009 Community ✅

Release Perfect World Private Server Installation Script

kisswdev22

New Member
This script use for install Perfect World Private Server to your VPS / local development.

Installation
Copy & Paste this script, and put at your root user directory and execute it.

Usage
Bash:
./installpw.sh
Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
Please make sure to update tests as appropriate.

License
MIT

Link:

Home Page: hrace009 Personal Blog
Forum: hrace009 Forum

Code:
...


error centos 7 fresh install >>



Error: Package: python2-libxml2-2.9.12-6.0.cf.rhel7.x86_64 (CityFan)
Requires: libxml2(x86-64) = 2.9.12-6.0.cf.rhel7
Installed: libxml2-2.9.1-6.el7_9.6.x86_64 (@updates)
libxml2(x86-64) = 2.9.1-6.el7_9.6
Available: libxml2-2.9.1-6.el7.5.x86_64 (base)
libxml2(x86-64) = 2.9.1-6.el7.5
Error: Package: python2-libxml2-2.9.12-6.0.cf.rhel7.x86_64 (CityFan)
Requires: libxml2.so.2(LIBXML2_2.9.11)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Error: Package: python2-libxml2-2.9.12-6.0.cf.rhel7.x86_64 (CityFan)
Requires: libxml2(x86-64) = 2.9.12-6.0.cf.rhel7
Installed: libxml2-2.9.1-6.el7_9.6.x86_64 (@updates)
libxml2(x86-64) = 2.9.1-6.el7_9.6
Available: libxml2-2.9.1-6.el7.5.x86_64 (base)
libxml2(x86-64) = 2.9.1-6.el7.5
Error: Package: python2-libxml2-2.9.12-6.0.cf.rhel7.x86_64 (CityFan)
Requires: libxml2.so.2(LIBXML2_2.9.11)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

=== Installing Software Depedency ===
Package php-mcrypt is obsoleted by php-pecl-mcrypt, trying to install php-pecl-mcrypt-1.0.4-1.el7.remi.7.2.x86_64 instead
Package php-pecl-imagick is obsoleted by php-pecl-imagick-im6, trying to install php-pecl-imagick-im6-3.5.1-3.el7.remi.7.2.x86_64 instead
Error: Package: php-pecl-zip-1.20.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(api) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-rar-4.2.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(zend-abi) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-ioncube-loader-11.0.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(api) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Error: mod_http2 conflicts with httpd-2.4.6-97.el7.centos.1.x86_64
Error: Package: php-pecl-mcrypt-1.0.4-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(api) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-rar-4.2.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(api) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-mcrypt-1.0.4-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(zend-abi) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-ioncube-loader-11.0.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(zend-abi) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-pecl-imagick-im6-3.5.1-3.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(zend-abi) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Error: Package: php-imap-7.2.34-9.el7.remi.x86_64 (remi-php72)
Requires: php-common(x86-64) = 7.2.34-9.el7.remi
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php-common(x86-64) = 5.4.16-48.el7
Error: Package: php-pecl-imagick-im6-3.5.1-3.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(api) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Error: Package: php-pecl-zip-1.20.0-1.el7.remi.7.2.x86_64 (remi-php72)
Requires: php(zend-abi) = 20170718-64
Installing: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Package glibc-2.17-325.el7_9.i686 already installed and latest version
Package glibc-2.17-325.el7_9.x86_64 already installed and latest version
Package libxml2-2.9.1-6.el7_9.6.i686 already installed and latest version
Package libxml2-2.9.1-6.el7_9.6.x86_64 already installed and latest version
Package compat-libstdc++-33-3.2.3-72.el7.i686 already installed and latest version
Package compat-libstdc++-33-3.2.3-72.el7.x86_64 already installed and latest version
Package libgcc-4.8.5-44.el7.i686 already installed and latest version
Package libgcc-4.8.5-44.el7.x86_64 already installed and latest version
Package pcre-8.32-17.el7.i686 already installed and latest version
Package pcre-8.32-17.el7.x86_64 already installed and latest version
Package 1:java-1.6.0-openjdk-1.6.0.41-1.13.13.1.el7_3.x86_64 already installed and latest version
Package wine-4.0.4-1.el7.x86_64 already installed and latest version
Package p7zip-16.02-20.el7.x86_64 already installed and latest version
Package perl-Digest-MD5-2.52-3.el7.x86_64 already installed and latest version
Package perl-Encode-Detect-1.01-13.el7.x86_64 already installed and latest version
warning: /var/tmp/rpm-tmp.Kozhl3: Header V4 DSA/SHA1 Signature, key ID 11f63c51: NOKEY
error: Failed dependencies:
perl(Net::SSLeay) is needed by webmin-1.981-1.noarch
perl(Data::Dumper) is needed by webmin-1.981-1.noarch
unzip is needed by webmin-1.981-1.noarch
Retrieving http://www.webmin.com/download/rpm/webmin-current.rpm
Failed to execute operation: No such file or directory
Failed to execute operation: No such file or directory
Failed to execute operation: No such file or directory
error reading information on service webmin: No such file or directory
Failed to start mariadb.service: Unit not found.
Failed to start httpd.service: Unit not found.
Failed to start php-fpm.service: Unit not found.
./installpw.sh: line 527: /etc/init.d/webmin: No such file or directory
 
Last edited by a moderator:

Donate

Our forum cost USD 20 per month, in the past i can cover that amount with my own cash, since COVID 19 and lost my job, i can't get any income at all and can't cover USD 20 for server rent.

If you like, you can help me to cover this amount with your best donation. Please click link bellow to help this community online and give your best donation

Donate With Paypal

Thank You

Top